Installing the binaries

The easiest way to install the MockableWebSecurity DLL is through NuGet. Once NuGet is installed and running you can get installation details on our package page.

Dependencies

Required

The only essential dependency is the .NET Framework version 3.5. The solution file is in Visual Studio 10 format, but there is not reason you can't create your own solution and add the MockableWebSecurity csproj files to it if you need an earlier version.

Optional

Ruby

MockableWebSecurity uses Ruby and Rake (ruby make) to perform various useful tasks. To use these, install Ruby 1.9.x. Once installed, install the bundler gem from the command line:

gem install bundler


And then use bundler to install all the other dependencies by running the following in your MockWebSecurity directory:

bundle

Last edited Aug 31, 2011 at 11:12 PM by apjanes, version 6

Comments

No comments yet.